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1 Introduction 
TOUGH2Viewer is a Java program capable of displaying unstructured (Voronoi complying) grids, 

locally refined and structured grids (complying with the MESHMAKER iTOUGH2 format). 

In particular, TOUGH2Viewer allows to navigate through a 3D grid compatible with the iTOUGH2 

data file format and see: 

� the thermodynamic variables and the material (namely, petrophysical properties) of each 

block; 

� maps of isovalues (2D) of all thermodynamic variables; 

� isosurfaces (3D) of all thermodynamic variables; 

� flows of mass and heat between blocks; 

� spatial profiles of thermodynamic variables, of a selected set of blocks, long a Cartesian 

directions; 

� time plot of thermodynamic variables of a selected block. 

All commands to manage a 3D visualization (zooming, pan, rotations) are CAD complying.  

In the following chapters, three driven examples will be presented: 
1. structured 2D grid generated with MESHMAKER. 

2. structured 3D grid generated with MESHMAKER. 
3. unstructured 3D grid generated with AMESH. 

All the example cases was obtained with the module EWASG as implemented in iTOUGH2.
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2 System Requirements 
 

The minimum system requirements to use TOUGH2Viewer are: 
1GB of RAM; 

100 MB of free disk space; 
Graphic card equipped with 512 MB RAM; 

 

Supported OS: Linux Ubuntu 8.04 or later, Windows XP, Vista, 7, 8. 

 

TOUGH2Viewer requires Java™ Runtime Environment (JRE) version 1.6.14 (or later) and the Java 

extension to display three dimensional graphics (Java3D) version 1.5.1 (or later) to be already 

installed on the system. To download installers and instruction manuals, please visit the official 

Oracle Web Site. 

3 Installation, execution and uninstallation instruction 

3.1 TOUGH2Viewer installation 
To install TOUGH2Viewer, user simply has to copy into a folder the compressed file 

(TOUGH2Viewer_v.X.zip where X indicates the version) containing the whole software programs 

and examples and, once finished copying, unzip it. The unpacked package of files consists of two 

subdirectories, dist (standing for distribution) and ExampleData. In the examples described in this 

manual, the supposed folder will be “D:\ T2Viewer”. So, at the end of the installation one should 

have a directory structure like the following: 

 
D:\T2VIEWER 

   
+---dist 
|   |   go.bat 
|   |   iTough2Viewer.jar 
|   |   launch.html 
|   |   launch.jnlp 
|   |   License.txt 
|   |   README.TXT 
|   |   splash.jpg 
|   |    
|   \---lib 
|           AbsoluteLayout.jar 
|           appframework-1.0.3.jar 
|           geoapi-2.3-M1.jar 
|           geoapi-pending-2.3-M1.jar 
|           gt-api-2.7-M4.jar 
|           gt-coverage-2.7-M4.jar 
|           gt-data-2.7-M4.jar 
|           gt-geometry-2.7-M4.jar 
|           gt-jts-wrapper-2.7-M4.jar 
|           gt-main-2.7-M4.jar 
|           gt-metadata-2.7-M4.jar 
|           gt-referencing-2.7-M4.jar 
|           gt-referencing3D-2.7-M4.jar 
|           gt-render-2.7-M4.jar 
|           gt-shapefile-2.7-M4.jar 
|           gt-shapefile-renderer-2.7-M4.jar 
|           gt-swing-2.7-M4.jar 
|           iText-2.1.5.jar 
|           jcommon-1.0.16.jar 
|           jfreechart-1.0.13-experimental.jar 
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|           jfreechart-1.0.13-swt.jar 
|           jfreechart-1.0.13.jar 
|           jsr-275-1.0-beta-2.jar 
|           jts-1.11.jar 
|           junit.jar 
|           miglayout-3.7-swing.jar 
|           netcdfAll.jar 
|           servlet.jar 
|           sgt-tutorial.jar 
|           swing-layout-1.0.4.jar 
|           swing-worker-1.1.jar 
|           swtgraphics2d.jar 
|           visad.jar 
|            
\---ExampleData 
    +---01_Structured_2D 
    |       2D.out 
    |       MESH 
    |        
    +---02_Structured_3D 
    |       3D_F-im-w.out 
    |       MESH.dat 
    |        
    \---03_Unstructured_3D 
        |   3d_unstruct_03.out 
        |   in.dat 
        |   segmt.dat 
        |    
        \---Maps 
            \---base_ss 
                    base_ss.dbf 
                    base_ss.prj 
                    base_ss.qix 
                    base_ss.shp 
                    base_ss.shx 
                    base_ss.xls 

3.2 TOUGH2Viewer execution 

3.2.1 Linux 

1. Navigate to the installation folder (/T2Viewer/dist/); 

2. open a terminal window in “dist” folder 

3. run the shell script, typing: 

./go.bat [↵]  

or typing: 

java -Xmx512M -jar iTough2Viewer.jar [↵] 

3.2.2 Windows 

1. Navigate to the installation folder (/T2Viewer/dist/); 

2. double click on file “go.bat” or open a DOS prompt and type: 

java -Xmx512M -jar iTough2Viewer.jar [↵] 

 

3.3 TOUGH2Viewer uninstallation 
To remove TOUGH2Viewer, just delete the installation folder containing all files. To obtain 
information about to remove JRE and Java3D, consult the JRE and Java3D manuals or visit the 

Oracle official web site. 
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4 Tutorial Examples 
These tutorials are designed to introduce the TOUGH2Viewer basic features, and should take less 
than an hour to be completed at all. Once finished the user will have the needed skills to explore a 

3D simulated model, plot variables and add to the 3D model Frame own maps. 
Following examples refer to Windows XP operating system. 

4.1 Structured grid model 2D 

This example is related to the visualization of a 2D grid (50×1×36). The files of this tutorial are in 

the path: “D:\T2Viewer\ExampleData\01_Structured_2D\”. 

Start TOUGH2Viewer, the main window of TOUGH2Viewer will be displayed, as shown in Fig. 1 

-. 

 

Fig. 1 - The TOUGH2Viewer empty main window 

4.1.1 Load Files 

From the main menu, select the File->Open structured grid menu item to open the "Open 

structured grid" dialog box (Fig. 2). 

 

 

Fig. 2 - The “Open structured grid” dialog box. 

Click the Mesh File button to display the "Open mesh" dialog box. Browse and select the 

“MESH.dat” file (\T2Viewer\ExampleData\01_Structured_2D\MESH.dat). 

Click the Open button to load this file. This operation takes few seconds .When loading is finished, 

the text box on the left side of the Mesh File button will contain the full path of the mesh file. 
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Click the Simulated File button to display the "Open Simulation" dialog box. Locate the iTOUGH2 

simulation output file “2d.out” and select it clicking on it. 

Then, click the Open button to start loading the file. The dialog progress bar will show the loading 

process. To close the dialog and return to the main window, click Close button. 

Now in the main window will be shown some geometric information about the model loaded (see 

Fig. 3). 

 

 

Fig. 3 - Main window with geometric information of the loaded grid. 

 

4.1.2 3D Block Model view 

In main menu, click the View->3D Block Model menu item, to display the "3D Block Model" 

dialog box and to have the default 3D Model Frame view (in this specific case only with one block 

in the y coordinate) of the grid, as shown in Fig. 4. The default variable showed in the dialog box is 

the first variable reported in the simulation output file (P for pressure in Fig. 4). Default action is 

ShiftXY. 

 

 

Fig. 4 - 3D Default representation of the Model, Top View. 

From Action combo box, select “FrontView” to change view and then the plot frame is updated as 

shown in Fig. 5. 



TOUGH2Viewer Tutorial 8 

 

 

Fig. 5 - 3D representation of the model, FrontView. 

Close the 3D Block model dialog by clicking the window icon  or the Close button.  

For more detail on commands available for 3D visualization management, see the example in 

chapter 4.2 and 4.3. 

 

4.1.3 2D Contour Plot visualization 

This functionality enables to plot the primary variables by means of contour lines. 

In the main menu, click the View->2D Contour plot menu item and the default "2D Contour plot" 

dialog box displays. From the Variable combo box, select P (Pressure), then click the Plot button 

(Fig. 6). 

 

 

Fig. 6 - Pressure contour map 

If one modifies plot’s parameter, click the Plot button to update the plot in the window (Fig. 7) is 
shown the contour of the temperature. 
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Fig. 7 - Temperature contour map 

Close the 2D Contour plot dialog by clicking the window icon  or the Close button.  

 

4.1.4 2D Flow Vector visualization 

This functionality gives a 2D vector representation of the flow heat or mass exchange among 

blocks. In the main menu of TOUGH2Viewer, click the View->2D Flow Vector menu item to 
display the 2D Flow plot dialog box (see  Fig. 8). The default plot uses the first variable present in 

the simulation output file, and the first time step (FHEAT in the figure). 

 

  

Fig. 8 - Vector map of the heat flow. 

From the Variable combo box, select the VEL(LIQ.) item. Move the time slider to the last time 
step. Check the Normalize vectors check box and type 100 in to Vector length text box. The 2D 

Flow vector dialog box now is as shown in Fig. 9. 
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Fig. 9 - Vector map of the variable VEL(LIQ.). 

Close the 2D Flow vector dialog by clicking the window icon  or the Close button. 

 

4.1.5 Statistics 

In the “Statistics” dialog is shown a table with maximum and minimum value for all 

thermodynamic variables, and it is possible to plot a selectable variable vs simulated time steps. 
From the menu bar, click the Analysis->Statistics menu item. The Statistics dialog box is displayed 

(Fig. 10). 

 

 

Fig. 10 - Min and Max value for simulation data. The default plot is first variable vs time. 

To change the time steps, use the "Time" combo box. To change the plotted variable, use the 

“Variable” combo box. 

Close the Statistic dialog by clicking the window icon  or the Close button. 

Exit from TOUGH2Viewer by clicking the window icon  or by the main menu item File->Exit. 
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4.2 Structured 3D Grid model 
This example manages a 3D model representing a spatial domain of 5000x5000x3600 m3 

discretized in 10×10×36 blocks and simulated for two time steps. 
Start TOUGH2Viewer (under Windows OS) by double clicking the go.bat batch file. 

 

4.2.1 Load Files 

From the TOUGH2Viewer main menu, click the File->Open structured grid menu item, and then 

the dialog box "Open structured grid" is displayed (see Fig. 11). 

 

 

Fig. 11 - Open Structured grid dialog. 

Click the Mesh File button to display the Open mesh dialog box and load the “MESH.dat” from the 

“\T2Viewer\ExampleData\02_Structured_3D\“ directory. 

Click the Open button to start loading the file. When loading is finished, the text box on the left side 

of the Mesh File button will contain the full path of the mesh file. 

Click the Simulated File button, and then the Open Simulated dialog box is displayed. Select the 

“3D_F-im-w.out” file and click the Open button to load it. The progress bar of the dialog will show 

the loading advancement. 

When the reading is complete, close the dialog by clicking Close button. Then, in the main window 

are shown some geometric information about the model. 

 

4.2.2 3D block model view 

From the main menu, click View -> 3D block model menu item. The "3D Block model" dialog box 

is displayed with the default setting, as shown in Fig. 12. 

 

 

Fig. 12 - 3D Block model window, top view. 
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From the “Variable” combo box, select the T variable (Temperature). Move the time step slider in 

position 2. Rotate both the model and the color scale. 

The plot of “3D Block model” dialog box, will be similar to that show in Fig. 13. 

 

 
 

Fig. 13 - 3D Block model box showing the Temperature variable at the time step 2. 

To split the 3D model Frame, from the “Action” combo box select the ShiftXY command, move 

the mouse on the 3D model frame and left click over a block. The model will be sectioned as shown 

in Fig. 14. 

 

 

Fig. 14 - 3D modelFrame  horizontally sectioned. 

From the Action combo box, choose ResetPositions command to reassembly the 3D model Frame, 

and then select the command Action->Get2Plot. Move the mouse on the 3D frame plot and left 

click on a block to select it. 

A Profiles dialog box is displayed, as showed in Fig. 15 and Fig. 16. One can select another 

variable to plot, acting on the “Variable” combo box, or change the time step by moving the time 

step slide bar. The “Domain” combo box allows to create a scatter plot of the chose variable, versus 

one of the Cartesian direction (x, y or z) or versus time. 
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Fig. 15 – Graph of the pressure versus the x coordinate. 

 

Fig. 16 – Graph of the pressure versus the z coordinate. 

 

Close the Profiles dialog box by clicking the window icon  or the Close button. 

 

Select the Action->ExpandZ command to explode the 3D Model Frame of the all layers (see Fig. 

17). 

 

Fig. 17 - ExpandZ command result. 
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Select both Action->ResetPositions and then Action->QuickInfo commands. Then clicking a 

block and to obtain information about it reported at the bottom of the “3D Block model” dialog box 

(see Fig. 18). 

 

 

Fig. 18 - QuickInfo command result, information are printed in a panel at the bottom of the window. 

Select the Action->SetVOI command to set the coordinates of a volume of interest. When the 

SetVOI dialog box is displayed. Select the "Enable" check box, click the Default button to set a 

default volume to be hidden (will be hidden a volume corresponding to half dimension on the three 

Cartesian direction) and click the Apply Hide VOI button. The 3D Block model is modified as 

showed in Fig. 19. 

 

Fig. 19 - SetVOI function applied to the model. 

From the Block appearance combo box, select RockTypes. The block scale colour is related to the 

rock type (as shown in Fig. 20). 
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Fig. 20 - 3D Block model in material color scale. 

Note that the color scale frame on the right is not update with rock type colors. The legend of rock 

type color is visible in a table present in the Option dialog box. From the main menu select Tools-

>Option to display the Option dialog box  and click 3D Block model object tab. To send to the 

printer the rock type color scale, click the Print button.  

Close the 3D Block model and the Option dialog by clicking the window icon  or the Close 

button. 

 

4.2.3 3D Flow Vector visualization 

This functionality gives a 3D vector representation of the heat or mass exchange among blocks.  

From main menu, click View->3D Flow Vector and the 3D Flow vector dialog box is displayed as 

shown in Fig. 21. 

 

 

Fig. 21 - Vector representation of the heat flow. 

From the Selection variable combo box select FHEAT. Move the slider to “2” and manage the 
model with usual CAD command. 

From the Action combo box, select Get 2D Plot command, then click a vector on the 3D model and 

then the default Vertical Flow Profiles dialog box is displayed (see Fig. 22). 
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Fig. 22 - Vertical heat flow profile. 

From Block combo box, is possible to change the block to use. 

From Variable combo box, select a different flow variable and from the Domain combo box 
choose z (versus z axis) or t (versus time) 

Close the Vertical Flow Profile dialog by clicking the window icon  or the Close button. 

Close the 3D Flow vector dialog by clicking the window icon  or the Close button. 

 

4.2.4 3D Iso Surface 

From TOUGH2Viewer menu bar, click View->3D IsoSurface (that is the three-dimensional 
analogue of the isoline), and then a 3D IsoSurface dialog box is displayed as shown in Fig. 23. 

 

 

Fig. 23 - 3D IsoSurface dialog. 

Click Plot iso surface button to obtain a IsoSurface dialog (see Fig. 24). 
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Fig. 24 - IsoSurface Dialog for pressure and time step 0.  

In the IsoSurface dialog (the base is the minimum value of the selected variable), rotate the model 

from top view with usual CAD commands. Move the slide bar to set a iso value or move the time 

step slide bar and observe surface modification. An example is shown in Fig. 25. 
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Fig. 25 - Dialog box for the pressure IsoSurface. 

Close the IsoSurface for... dialog by clicking the window icon  or the Close button. 

Close the 3D Iso Surface dialog by clicking the window icon  or the Close button. 

 

4.2.5 2D Contour Plot visualization 

This functionality enables to plot the primary variables by means of contour lines. 

From main menu, click View->2D Contour plot. A Contour Plot dialog is displayed. From the 

Variable combo box, choose P (Pressure), move the slide bar to 2, select the “XZ” item from 

Sectioning Plane combo box. In the y= text box, type 500 (to specify the y coordinate of the 

sectioning plane). Click the Plot button and the Contour Plot dialog is updated as shown in Fig. 

26. 
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Fig. 26 - 2D Contour Plot for the Pressure (Pa). 

Close the Contour Plot dialog by clicking the window icon  or the Close button. 

To get basic statistic information about the simulated data, from main menu, click Analysis-

>Statistics menu item and then the “Statistics” dialog box is displayed (see pag. 10). 

Exit form TOUGH2Viewer by clicking the window icon  or by File->Exit menu item. 

 

4.3 Unstructured 3D grid model 
This example is related to an unstructured grid model, built using a special GIS GRASS version 

adapted to create locally refined grids. 

Start TOUGH2Viewer (Windows OS) by double clicking the batch file go.bat then the main 

window of TOUGH2Viewer is displayed, as shown in Fig. 27. 

 

 

Fig. 27 - TOUGH2Viewer empty main window 

4.3.1 Load Files 

From main menu, click the File->Open unstructured grid menu item.  

The Open unstructured grid dialog box will be displayed (Fig. 28). 
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Fig. 28 - Open unstructured grid dialog box 

Click the In File button to open the Open In dialog box and select the file called “in.dat” from the 

subdirectory “\T2Viewer\ExampleData\03_Unstructured_3D\”. 

Click Open to start reading this file. Once finished the text box on the left side contains the full path 

of the file. 

Click the Segmt File button to open the Open Segmt dialog box and select the “segmt.dat” file. 

Click Open to start loading this file. When the loading is finished, the text box on the left side 

contains the full path of the file. 
Click the Simulated File button to open the Open out dialog box and select the 

“01_ss_dir_01.out” file. 
Click Open to start loading this file. The progress bar of the Open unstructured grid dialog shows 

the reading process. Close the Open unstructured grid dialog by clicking Close button to return to 
the main window. 

The main window now shows some geometric information about the loaded model (see Fig. 29). 
 

 

Fig. 29 - TOUGH2Viewer main window that summarizes some geometric data of the loaded numerical model. 

 
In order to to load shapefiles to be included in the 3D Model Frame, from the main menu select the 

File->Import shapefile menu item and the Import shapefile dialog box is opened (Fig. 30)  
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Fig. 30 - Import shapefile dialog Box. 

Click the add new ... button to open the LoadShapeFile dialog box (Fig. 31). 

 

 

Fig. 31 - Dialog Box to load shape files. 

Click the Shape File... button to display the Open dialog box and navigate to the base_ss folder. 
In particular go to ExampleData\03_unstructured_3D\Maps\base_ss folder and select the 

“base_ss.shp” file (Fig. 32). 
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Fig. 32 - Dialog Box to select the file to be loaded. 

To obtain a 2D preview of the base_ss.shp file, click Show Preview button of the Load Shape File 

box and the Shape file preview window is displayed (Fig. 33). 

 

 

Fig. 33 - 2D Preview of the base_ss.shp file 

Close the Shape file preview window by clicking the window icon . From the LoadShapeFile 

dialog box, select “Quota” item in the dbf field combo box (to load from a dbf file the elevation 
quote of the polylines object) (Fig. 34a) and click Import button (Fig. 34b). 
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(a) (b) 

Fig. 34a, b - LoadShpFile Dialog window 

 

The Import shapefile window now will be as showed in Fig. 35. The maximum number of loaded 

maps depends on the quantity of free RAM memory available.  

 

 

Fig. 35 - Import shapefile window. The table resume imported shape files. 

By double clicking the color bar near the file name, the Choose a color... window dialog box is 

displayed to change the color of polylines (Fig. 36). Choose a color to plot the curve of the shape 

map and click OK, then close the LoadShapeFile window by clicking the window icon  or the 

Close button. 
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Fig. 36 – “Choose a color …” dialog box window. 

Close the Import shapefile dialog window by clicking the window icon  or the Close button. 

 

4.3.2 3D Block model view 

From TOUGH2Viewer menu bar, click View -> 3D block model menu item and the 3D Block 

model dialog window display, as shown in Fig. 37. 

 

 

Fig. 37 - Top view of the 3D Block model. 

 
The isolines and surface representing the base_ss.shp loaded in the previous step now are inside the 

model, and can be showed. 
One can rotate, zoom, pan the model etc. using the mouse. To change variable to be showed, select 

it from Variable combo box. To change the time step, move the slide bar and automatically the plot 

will be update. 

From the Action combo box, select SetVOI. A SetVOI dialog box is displayed. In the panel Hide 

VOI, check the Enable checkbox, click both Default and Apply Hide VOI buttons (Fig. 38).  
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Fig. 38 - SetVOI dialog window. 

Close the SetVOI dialog by clicking the window icon  or the Close button.  

Is possible to rotate the view and minimize/enlarge the 3D frame by clicking the up black arrows 

(right-oriented arrow to minimize, left-oriented arrow to enlarge). The view of the model is now as 

shown in Fig. 39. 

To obtain block information, choose Action->QuickInfo, then click a block on the 3D frame. At 
the bottom of the dialog, a set of information about the selected block will be displayed (Fig. 39, 

(a)). These information will be automatically update when another variable or time step is selected 
(Fig. 39, (b)). 

 

 (a) 

(b) 

Fig. 39 - (a) 3D model partially showed and block selected (white block); (b) information related to the selected block. 
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From the Action combo box, select FindBlocks and the Find Blocks dialog box is displayed (Fig. 

40). From the combo box, select a specific block (by the TOUGH2 name) and automatically in the 

Block information panel some information about it are showed and in the 3D model frame it will 

be highlighted. 

To unselect the block, click unselect button. Close the Find Blocks dialog by clicking the window 

icon  or the Close button. 

 

 

Fig. 40 - Find Block dialog box. 

From the Action combo box, select SnapShot to display a SnapShot Preview dialog box that 

contains an image of the three-dimensional model (Fig. 41). With the File->Save as... menu item is 
possible to save the image (in png format) or send it directly to the printer by File->print menu 

item. Close the SnapShot dialog box by clicking the window icon  or via the File->Exit menu 
item. 

 

 

Fig. 41 - Snapshot Preview window dialog box. 

To repaint each block in material scale color (Fig. 42), from the Action combo box of the 3D Block 

model dialog box, execute the following commands: 
� ResetPositions; 

� FrontView; 
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� SetVOI and in the setVOI dialog box uncheck Enable check box and close setVOI 

dialog box; 

From Block Appearance of the 3D Block model dialog box, select RockType. 

 

 

Fig. 42 - 3D Block Model front view. Material color scale. 

From main menu, choose Tools-> Options, then click 3D Block model object tab to open the 

Options dialog box (Fig. 43). 

 

 

Fig. 43 - Options dialog window. 

To obtain the view showed in Fig. 45, in the “Material” table of 3D Block model Object tab, 
uncheck the check box of column Visible for: 

ATMOS, CAPRO, SHAL1, SHAL2, VOLCA as show in Fig. 44. Only the materials SPIMP and 

SPLIQ are kept visible. 
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Fig. 44 - Options dialog with modified parameters. 

To set not visible the contour line or the surface of shapefiles, uncheck the respective check box in 

the 3D Block model Object tab. Close the Options windows using the window icon , or the 

Close button. The 3D Block model view now will appear as showed in Fig. 45.  

 

 

Fig. 45 - 3D Block model.  

In the Options dialog window, 3D Block model Object tab, restore ATMOS, CAPRO, SHAL1, 

SHAL2, VOLCA again visible. 
In the 3D Block model, from the Action combo box select Get2DPlot command. Click a block in 

the 3D frame and a Profiles dialog box is displayed. 
From the slider menu select the time step “6”. The graph will be update as shown in Fig. 46. 
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Fig. 46 - Profiles dialog which shows the pressure values along z axis. 

Close the Profiles dialog box by clicking the  windows icon or the Close button. 

In the Options dialog box, click on the Visualization Filter tab, select the T variable. In the min 
text box, type “270.0” and click the setNewValue button, and select the HideOutOfRange check 

box. In this way only blocks with temperature value between 270.0 and 291.01 °C are visible, note 
that also the colour scale, on the right frame, has changed as shown in Fig. 47. 

In the 3D Block model window, select T from Variable combo box and move the slider at position 
“6-th” (last time step present in this simulation output file).  

 

 

Fig. 47 - Bottom filtered view of the 3D model with modified color scale. 

Close the 3D block Model by clicking the  windows icon or the Close button. 

 

4.3.3 3D Flow Vector visualization 

This functionality gives a 3D vector representation of the heat or mass exchange among blocks. 

Select the View->3D Flow Vector menu item. A 3D Flow Vector window opens, showing the 

default variable FHEAT, as shown in Fig. 48. 
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Fig. 48 - 3D Flow vector default viewing. 

From the Variable combo box, select Vel(GAS) item and move the slider to 1. With the usual CAD 

command zoom and rotate the model in the desiderated position (Fig. 49). 

 

 

Fig. 49 - 3D Flow model at the time step 1 for the variable VEL(GAS). 

Close the Flow profile window  by clicking the  windows icon or the Close button. 

Close the 3D Flow vector  window by clicking the  windows icon or the Close button. 
 

4.3.4 3D Iso Surface 

Select the View->3D Iso Surface menu item. 

Open a 3D Iso Surface dialog (Fig. 50) and from the Variable combo box, select T (default is P). 
Leave other parameters as default and click Plot iso surface button. Wait few second to complete 

the interpolation process, and then a new IsoSurface window opens to plot the selected variable. 
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Fig. 50 - 3D IsoSurface dialog box. 

 

In this window, move the first continuous slider to 270 °C. The plot windows will appear as like as 
shown in Fig 52. To see evolution of isosurface by time steps, move the time step slider under 

continuous slider. Click the Properties button to change colour background, to switch from parallel 
to perspective view, to change axis colour or hide the thin box. 

 

 

Fig. 51 - Isosurface for T=270°C, time step “6”. 

Close the IsoSurface for T … and the 3D Isosurface window by clicking the  windows icon or 

the Close button. 

 

4.3.5 2D Contour map 

Select the View->2D Contour map menu item and a 2D Contour plot window will open.  

In the 2D Contour plot window, set the Sectioning plane combo box to XZ, and type “4745000” 

(vertical XZ section at y=4745000 m), move the slider at position “6-th” (last time step present in 

this simulation output file) and click the Plot button. A Contour Plot window will be displayed as 

shown in Fig. 52. 
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Fig. 52 – Temperature isolines contour map. 

After having adjusted the parameter of plotting, click the Plot button to update the graph. 

Close the 2D Contour plot window by clicking the  windows icon or the Close button. 

 

4.3.6 Statistics 

Click the Analysis-> Statistics menu item. The Statistics dialog box is displayed (see pag. 10.). 
 

Exit form TOUGH2Viewer by clicking the window icon  or by File->Exit menu item. 
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